Increased Response Times
Incident Report for Kevel
Resolved
This incident has been resolved.
Posted Jul 19, 2022 - 12:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2022 - 09:04 EDT
Investigating
We are investigating a degradation in service resulting in increased response times for a small percentage of customers.
Posted Jul 19, 2022 - 08:37 EDT
This incident affected: Ad Serving.