AWS Lambda Outage Impacting Kevel Management UI/API + Reporting
Incident Report for Kevel
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:15 EDT
Monitoring
Amazon reported the outage as resolved; they are recovering and processing data.


The Kevel Management UI, Management API, and Ad Serving are operational. Reporting remains in a degraded status while backlogged data is processed.
Posted Jun 13, 2023 - 18:19 EDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2023 - 16:53 EDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2023 - 16:19 EDT
Investigating
Amazon reported an outage at 18:51 GMT affecting their Lambda service. Amazon has identified the root cause and is working on a fix.

The following Kevel services will be affected:

Reporting: Reports can be run at this time; however, reporting data may be delayed.
Custom targeting: Flights that contain custom targeting can now be saved.
Ad serving: While ad delivery isn't affected, ad balancing will be

AWS updates can be accessed here:https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 15:47 EDT
This incident affected: Ad Serving, Management UI, Reporting, and Management API.