We are currently investigating an issue with Kevel reporting systems.
Incident Report for Kevel
Resolved
We resolved the issue of delayed Report processing. All affected reports have been processed. The incident is now resolved.
Posted Nov 25, 2024 - 10:57 EST
Identified
We identified an issue impacting Reporting. Reports are processing through the system. We'll keep you updated along the way.
Posted Nov 25, 2024 - 10:17 EST
This incident affected: Reporting.