Increased ad serving latency

Incident Report for Kevel

Resolved

We have rolled out a fix and ad serving latency is back to normal.
Posted Sep 14, 2021 - 12:41 EDT

Identified

We have identified the issue and are working on mitigation. Response times should be mostly back to normal.
Posted Sep 14, 2021 - 12:33 EDT

Investigating

We are investigating elevated ad serving latency in the US-East region.
Posted Sep 14, 2021 - 11:47 EDT
This incident affected: Ad Serving.