Ad Balancing & Publication Delays

Incident Report for Kevel

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 16:23 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 25, 2025 - 16:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 15:42 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2025 - 15:31 EDT

Investigating

We identified an issue with our ad publication & balancing systems starting 2025-04-25 18:29 UTC. This is being investigated with high priority. This impacts us-east only.
Posted Apr 25, 2025 - 15:09 EDT
This incident affected: Ad Serving.