We are currently investigating an issue with Kevel ad serving systems

Incident Report for Kevel

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 10:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 10:18 EDT

Identified

We have identified the issue and are working on a fix.
Posted Mar 25, 2025 - 09:59 EDT

Investigating

We identified an issue impacting ad serving in us-east-1, beginning at 13:10 UTC. An investigation is underway with our team. We'll keep you updated along the way.
Posted Mar 25, 2025 - 09:35 EDT
This incident affected: Ad Serving.