Forecast Response Issue

Incident Report for Kevel

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 12:24 EDT

Monitoring

We identified an issue impacting Forecast. Some instances were not responding to Forecast requests or Forecast API requests from ~15:15 UTC to ~15:55 UTC on July 31, 2025. A fix has already been deployed and we are monitoring.
Posted Jul 31, 2025 - 12:09 EDT
This incident affected: Forecast.