Errors Saving Changes in the Ad Server UI

Incident Report for Kevel

Resolved

Confirming this is now resolved. Please find a summary below.

Between ~19:38 and ~22:35 UTC on September 17, 2026, saving an ad through the Ad Server UI may have returned an error even though the change was applied successfully. Users who retried after seeing the error may have created duplicate ads.

We recommend reviewing any ads created or edited during this window and removing any duplicates.
Posted Sep 17, 2026 - 19:25 EDT

Monitoring

A fix has been deployed and saving changes in the Ad Server UI is working as expected. We are continuing to monitor.
Posted Sep 17, 2026 - 18:48 EDT

Identified

We are currently investigating an issue impacting some users saving changes made to Ads through the Ad Server UI.

Changes made through the Management API are not affected.

We have identified a likely cause and are working to resolve it.
Posted Sep 17, 2026 - 18:13 EDT
This incident affected: Management UI.