Degraded Ad Serving for US-East-1

Incident Report for Kevel

Resolved

The issue has been resolved and system performance has remained stable. We will continue to monitor as a precaution.
Posted Mar 31, 2026 - 10:12 EDT

Update

System performance has remained stable following the applied mitigation. We are continuing to monitor to ensure ongoing reliability.
Posted Mar 31, 2026 - 06:09 EDT

Monitoring

A mitigation has been applied and we are currently monitoring the system to ensure continued stability.
Posted Mar 31, 2026 - 05:00 EDT

Update

We are continuing to investigate the root cause. In the meantime, we have scaled additional capacity in the affected region, which has restored stability to ad serving. We will provide further updates as we learn more.
Posted Mar 31, 2026 - 02:25 EDT

Investigating

We are currently investigating degraded ad serving performance in the us-east-1 region.
Posted Mar 31, 2026 - 01:05 EDT
This incident affected: Ad Serving.