Increased Response Times for Events in EU Central 1 Region

Incident Report for Kevel

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 16:20 EST

Investigating

We are currently investigating an increase in response times for Events (Impressions and Clicks) in EU Central 1 Region. An investigation is underway with our team. We'll keep you updated along the way.
Posted Feb 24, 2025 - 16:17 EST
This incident affected: Ad Serving.